6.7L  Cummins Forum

6.7L Cummins Forum


Go Back   6.7L Cummins Forum > Cummins 6.7L OEM, Performance and Aftermarket Forums > Cummins 6.7L Turbo Diesel > Programmers and Chips
Home Forums Photo Gallery Members List Calendar
Register FAQ Search Today's Posts Mark Forums Read




Welcome to the 6.7L Cummins Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05-09-2015, 07:52 PM
Junior Member
 

Join Date: May 2015
Posts: 1
Default 02 sensors

i have had my 02 sensors changed 5 times the last pair were gold plated i am sick and tired of exhaust filters and o2 sensors. i need help any advice .....ps even my dealer said i should trade it in our chip it.
Reply With Quote
Links
  #2 (permalink)  
Old 05-11-2015, 06:38 PM
08RAM2500's Avatar
Senior Member
 

Join Date: Nov 2012
Location: New Richmond, Wisconsin
Posts: 267

Default

Sorry to hear that no idea what thats like been running with deletes since i bought it never had a problem except with that crappy too small vgt turbo
__________________
2008 Ram 2500 6.7, 68RFE, 3.55 Rear, dpf/egr delete, H&S Tuner 175 tune W/Overdrive, AFE 4" exhaust, Quadzilla Scout II Monitor, s366, steed speed manifold
2002 Ram 1500 5.9L GAS

EPA (Economy Poisoning Agency)
Reply With Quote
  #3 (permalink)  
Old 05-14-2015, 05:15 PM
Squid's Avatar
Head Flunky
 

Join Date: Sep 2007
Location: South Central Kansas
Posts: 1,858

Default

What year? I too had to delete everything in my 07 after 150,000 miles
__________________

2007.5 Dodge Ram 3500 HD,QC, 6.7L Cummins, 6speed Auto, 4X4, Bighorn Edition.
Click for installs: Carr Steps PML Diff Cover Edge Juice with Attitude Volant Intake Hankook ATM RF10
Reply With Quote
  #4 (permalink)  
Old 07-08-2015, 12:31 PM
Junior Member
 

Join Date: Mar 2014
Posts: 2
Default

first time to ask a ?, have replaced the #1 o2 sensor once and now the obd says heater oxy sensor, heater control circuit low bank 1. is that the small sensor forward of the 02 sensor
Reply With Quote
Links
Reply


Thread Tools
Display Modes



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:10 PM.

SquidWorkz is Infiniti EX35_ FJ Cruiser_ Nissan Rogue_ Mahindra Trucks_ Toyota Venza_ Ducati Superbikes_ Nissan Titan_ Toyota Tundra
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0