6.7L  Cummins Forum

6.7L Cummins Forum


Go Back   6.7L Cummins Forum > Dodge Cummins Stuff > Shade Tree Troubleshooting
Home Forums Photo Gallery Members List Calendar
Register FAQ Search Today's Posts Mark Forums Read

Shade Tree Troubleshooting Members Helping Members.




Welcome to the 6.7L Cummins Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-19-2011, 03:05 PM
Member
 

Join Date: Apr 2011
Posts: 45
Default "Service Required; See Dealer Now"

I am new here, so before I define my problem I would like to say "Hi" and thanks in advance for any advice. I have a 2008 6.7L 4x4 2500 with 78000 miles on it. I bought the truck used with 75000 miles on it. Immediately after buyint the truck, I ordered a H&S performance DPF delete kit with the mini maxx tuner. I put roughly 500 miles on the truck waiting for the kit to arrive with no problems. Before the kit I was getting 13.5 mpg empty (I didn't pull anything without the kit, so I have no mileage to report). The kit was installed by a trusted mechanic who has lots of experience with the Cummins. The kit's results were great. Great power (even though I keep it turned to the lowest power setting), Fuel economy went to an average of 19.0 mpg empty and 11.5-12.0 no matter what I've pulled. The bad news is I now have "service required: see dealer now". I ran the diagnostics for codes on the mini maxx and it is showing no codes. I did the brake twice and gas twice to reset "perform service" but that didn't help. Called local dodge dealership and guy says the warning comes on roughly every 60,000 miles and the EGR needs cleaning out. Everyone else says this isn't the case b/c the EEGR was unplugged and disabled when the DPF delete was installed. Also have been told by H&S representative that this "service required" warning will come on when the CCV filter needs changing roughly every 67,500 miles. NOW!! finally we have arrived at my question. When I change the CCV filter will that automatically reset the "service required" message (i doubt it) or what do I do to reset it myself?

Last edited by cmccarra56; 04-22-2011 at 08:52 PM..
Reply With Quote
Links
  #2 (permalink)  
Old 04-20-2011, 07:21 AM
Squid's Avatar
Head Flunky
 

Join Date: Sep 2007
Location: South Central Kansas
Posts: 1,835

Default

Here ya go. Dodge/Cummins 6.7L PERFORM SERVICE INDICATOR - RESET
__________________

2007.5 Dodge Ram 3500 HD,QC, 6.7L Cummins, 6speed Auto, 4X4, Bighorn Edition.
Click for installs: Carr Steps PML Diff Cover Edge Juice with Attitude Volant Intake Hankook ATM RF10
Reply With Quote
  #3 (permalink)  
Old 04-20-2011, 08:55 AM
Member
 

Join Date: Apr 2011
Posts: 45
Default

Thank you for the reply. Is there some magic trick to doing this? I read several threads on other blogs and also on this blog about reseting the perform service message before asking my question b/c I have tried this a few times with no luck. Also, I don't know if the overhead message of "service required; see dealer now" is the same thing people are calling "perform service". Is this the case? Thank you for any and all information.
Reply With Quote
  #4 (permalink)  
Old 04-20-2011, 07:45 PM
Squid's Avatar
Head Flunky
 

Join Date: Sep 2007
Location: South Central Kansas
Posts: 1,835

Default

Yup, it's the same but make sure you're using the brake pedal and not the gas pedal.
__________________

2007.5 Dodge Ram 3500 HD,QC, 6.7L Cummins, 6speed Auto, 4X4, Bighorn Edition.
Click for installs: Carr Steps PML Diff Cover Edge Juice with Attitude Volant Intake Hankook ATM RF10
Reply With Quote
  #5 (permalink)  
Old 06-24-2011, 01:56 AM
Junior Member
 

Join Date: Jun 2011
Posts: 2
Default Service Required> see dealer now

I can not get this to clear from my truck, my mini maxx says all good, I don't have anything related to the egr. I have had all this installed for about 2 months with no problems. I have 42000 miles. Any help?
Reply With Quote
  #6 (permalink)  
Old 07-10-2011, 07:42 AM
Member
 

Join Date: Apr 2011
Posts: 45
Default

I have tried SEVERAL different methods. No luck. I've been working on this problem for over 6 months. I have taken the truck to Dodge, uploaded latest software into H&S tuner, disconnected battery cables, discharged capacitors, done the brake and gas pedal dance, no luck with anything so far. PGW Hunter....if you discover something that works please post it on here so I can try it too. I will do the same.
__________________
2008 Dodge 2500 4x4 6.7L Quad Cab. K&N filter. H&S DPF delete (turbo back). EGR disconnected. Mini Maxx tuner (running on 120hp setting). B&W hideaway hitch.
Reply With Quote
  #7 (permalink)  
Old 07-10-2011, 05:28 PM
Junior Member
 

Join Date: Jul 2011
Location: Garner, NC
Posts: 5

Default

I just got done completing the EGR cooler and valve cleaner, along with CCV replacement & oil change. Once completed, turned key on, two full presses of brake pedal plus two quick pushes of fuel pedal to floor and key off...key on, three presses of brake pedal within 10 seconds, key off. Fired truck up, and no overhead messages!!! Yeah for me on first try (with service required message). After I shut truck down after assessing for any leaks...did the three times on quick to check for any possible codes...got the -------- and then ---done---!!!! No codes...Squid and Morbius you guys are the bomb...without you two it would've cost me $8-900 for this service...with your guys assistance...about $150 between CCV filter, gaskets and cleaner and a lot more knowledge about my truck!!!
Reply With Quote
  #8 (permalink)  
Old 07-12-2011, 04:14 PM
Junior Member
 

Join Date: Jul 2011
Posts: 14
Default

Hey all, the newbie again here, my '07 3500 Mega Cab just turned 67,500 and i got the perform service on the overhead, that was my reason for joining this forum i found tons of information on the service that needs to be done, thankfully, after calling my local dodge dealership and finding out its 8 bills for them to do this. I kept reading that the CCV filter was used on '07.5 and newer, so out of curiosity i worte Dodge a quick email to find out if my truck was a half year model or not and was informed that my truck was built in Feb. of '07 and did not have a CCV filter on it.....anybody know if that is true or not?? My truck is all stock with the 6.7, bought it used with 40+K on the odometer, the only problem i had was an exhause leak, when i looked under the truck, somebody had cut the exhaust system 6 inchs below the turbo, and just had three tack welds holding it together, i have a sneaky suspision that it had a different exhaust on it, and possibly an EGR deleter kit as well as all of that looked brand new under the hood compared to the rest of the engine, anyway back to my question, how do i know if there is a CCV filter without removeing the top cover above the valve cover??? Oh yea, my service book also says to replace the EGR filter??? I can not find any information on a filter for the EGR anywhere.
Thanks in advance for any and all help, suggestions ect....
Also thanks for an awesome site, incredible information, and some great discussions on a few different areas of modifacations!
Reply With Quote
  #9 (permalink)  
Old 07-15-2011, 08:41 PM
Junior Member
 

Join Date: Jul 2011
Posts: 14
Default

I cleaned my EGR valve, it was not dirty at all, but took it apart and used a little carb cleaner to remove what little soot was on it, i don't think i am going to clean the cooler, but still need to know if i have a CCV filter or not, i am thinking it has to have some sort of filter on it, and also where is or is there a filter for the EGR Valve, if i need to change them out i would like to before we take off next week along with my regular oil and filter change, tire rotation, air filter clean ect....So if anybody reads this and has any idea if i have these on my truck please let me know.
thanks again in advance for any and all help
Reply With Quote
  #10 (permalink)  
Old 07-18-2011, 05:12 PM
Junior Member
 

Join Date: Jul 2011
Posts: 14
Default

Since i can't seem to get anybody to answer my questions concerning the CCV and EGR filters on my truck, i called several auto parts stores today, Napa, Auto Zone and Carquest, all three places told me my truck dosen't call for either of these filters, there has to be a crankcase vent on the engine, if there wasn't, seals and gaskets would be all gone the first time the engine was fired up, so we know there is a vent, but is there a filter on this truck....I also sent Geno's garage aan email to see if they could help me out with this delima, Dodge and the auto parts stores tell me this truck does not have a ccv filter on it, can they all be wrong?? I would gladly forward the email i got from Dodge to anyone out there that wanted to see it, just so you know i'm not nuts!!
HELP PLEASE
Reply With Quote
Links
Reply


Thread Tools
Display Modes



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:48 PM.

SquidWorkz is Infiniti EX35_ FJ Cruiser_ Nissan Rogue_ Mahindra Trucks_ Toyota Venza_ Ducati Superbikes_ Nissan Titan_ Toyota Tundra
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0